Kritik İlerleme Hatası WS_FTP Yazılımını Etkiliyor - Dünyadan Güncel Teknoloji Haberleri

Kritik İlerleme Hatası WS_FTP Yazılımını Etkiliyor - Dünyadan Güncel Teknoloji Haberleri
2’den önceki WS_FTP Sunucusu sürümlerinde Bu tür kusurlar hizmet reddi saldırılarına, bilgi sızıntılarına ve RCE’ye olanak sağlayabilir ”

WS_FTP’yi Hemen Yamalayın

Progress, güvenlik açıklarını giderdi ve etkilenen tüm ürünler için sürüme özel düzeltmeler yayınladı



Progress Software, son aylarda ikinci kez kurumsal güvenlik ekiplerinin her şeyi bırakıp kuruluşlarını dosya aktarım yazılımındaki (bu kez yaklaşık 40 milyon kişi tarafından kullanılan WS_FTP dosya aktarım ürünü) kritik güvenlik açıklarına karşı korumak için hızlı hareket etmelerini istiyor

Progress, “Tam yükleyiciyi kullanarak yamalı bir sürüme yükseltmek, bu sorunu çözmenin tek yoludur” dedi Şirket, müşterilerini derhal güncelleme yapmaya veya önerilen azaltma adımlarını uygulamaya çağırıyor; Progress, WS_FTP’nin desteklenmeyen sürümlerini kullanan kuruluşların da en kısa sürede desteklenen ve sabit bir sürüme yükseltme yapmasını istiyor NET serileştirme güvenlik açığı olarak tanımladı; bu, bir uygulamanın yaygın olarak karşılaştığı bir hata türüdür

Assetnote araştırmacılarından biri 28 Eylül’de X’te (eski adıyla Twitter) yayınlanan bir gönderide şirketin şu planlarını duyurdu: tam bir yazı yayınla 30 gün içinde keşfettikleri sorunlar hakkında veya istismarın ayrıntıları bu tarihten önce kamuya açıklanırsa “Yükseltme çalışırken sistemde bir kesinti olacak “Saldırganlar ayrıca WS_FTP Sunucusu dosya yapısının bağlamından kaçabilir ve temel işletim sistemindeki dosya ve klasör konumlarında aynı düzeydeki işlemleri (silme, yeniden adlandırma, rmdir, mkdir) gerçekleştirebilir

Hataların en ciddisi, herhangi bir kullanıcı etkileşimi olmadan, önceden kimlik doğrulamalı uzaktan kod yürütülmesine (RCE) izin verir 100’den fazla kuruluş çoğu Cl0p fidye yazılımı grubu tarafından yapılan bu kusurdan yararlanan saldırıların kurbanı oldu “[Rapid 7 has] belirli bir yol altındaki herhangi bir URI’ye bir HTTPS POST isteğiyle ve bazı belirli çok parçalı verilerle kolayca yararlanılabileceği doğrulandı 2’den önceki sürümlerini etkiler ve belirtildiği gibi saldırganlara, etkilenen sistemlerde ön kimlik doğrulama RCE elde etme yolu sağlar Condon, kimlik doğrulamaya ve kullanıcı etkileşimine gerek yok” diyor ”

Özellikle Progress’in bu hafta açıkladığı güvenlik açıkları, WS_FTP Sunucusu Geçici Aktarım Modülünde ve WS_FTP Sunucu yöneticisi arayüzünde mevcut

Açıklamada, “Bu güvenlik açıklarını Assetnote’taki araştırmacılarla birlikte sorumlu bir şekilde açıkladık” denildi Orta düzey güvenlik kusurları şunları içerir: CVE-2023-40048, bir siteler arası istek sahteciliği (CSRF) hatası; Ve CVE-2023-40049diğerlerinin yanı sıra bir bilginin ifşa edilmesi sorunu Progress, Assetnote’tan iki araştırmacının kusurları keşfettiğini ve bunları şirkete bildirdiğini belirtti

Tanium’un baş güvenlik danışmanı Timothy Morris, “WF_FTP’nin zengin bir geçmişi var ve genellikle BT ve geliştiriciler arasında kullanılıyor” diyor ve iyi bir yazılım envanteri bulunduran ve/veya ortamlarında yazılım kullanımını izlemeye yönelik programlara sahip kuruluşların, WS_FTP’nin savunmasız örneklerini takip etmek ve güncellemek nispeten kolay bir zaman 8 Ayrıca grupta maksimum şiddete yakın bir hata ve yüksek ya da orta şiddette altı hata da yer alıyor 4 ve 8

Dosya Aktarımında Devam Eden Hatalar Nasıl Ortaya Çıkarılır

Diğer sorunlar arasında iki adet yüksek önemde hata (CVE-2023-40045 Ve CVE-2023-40047), bunlar kötü amaçlı JavaScript’in yürütülmesine olanak tanıyan siteler arası komut dosyası çalıştırma (XSS) güvenlik açıklarıdır 8

Bu arada diğer kritik hata ise dizin geçişindeki güvenlik açığıdır ”

“Ortamı taramak için yazılım envanteri araçlarıyla başlardım (uygulama yüklü, hizmet çalışıyor) ve ardından dinlenme halindeki WS_FTP sürümlerini aramak ve bulmak için ikincil bir yöntem olarak dosya aramalarını kullanırdım” diyor

Kritik Güvenlik Açığı “Kolayca Suistimal Edilebilir”

Şu şekilde izlenen maksimum önem derecesine sahip güvenlik açığı: CVE-2023-40044 WS_FTP Sunucusunun 8 7 “Şu anda bu güvenlik açıklarından yararlanıldığına dair herhangi bir belirti görmedik Dizin geçiş kusurlarıveya yol geçişi, temelde saldırganlara yetkisiz dosya ve dizinlere erişme yolu sağlayan güvenlik açıklarıdır Progress, sorunu bir Şu ana kadar, 2 4 ve 8

Progress, danışma belgesinde “Bir saldırgan, yetkili WS_FTP klasör yolunun dışındaki dosya ve klasörler üzerinde dosya işlemleri (silme, yeniden adlandırma, rmdir, mkdir) gerçekleştirmek için bu güvenlik açığından yararlanabilir” uyarısında bulundu





siber-1

Yeni güvenlik açıklarıyla ilgili haberler, binlerce Progress müşterisinin MOVEit dosya aktarım teknolojisindeki sıfır gün güvenlik açığından etkilenmesine rağmen geliyor şirketin açıkladığı Mayıs ayı sonlarında 7

Progress’ten bir sözcü, Dark Reading’e e-postayla gönderilen bir açıklamada, şirketin şu ana kadar herhangi bir kusuru hedef alan herhangi bir istismar faaliyeti belirtisi görmediğini söyledi

Rapid7’deki güvenlik açığı araştırması başkanı Caitlin Condon, şirketinin araştırma ekibinin güvenlik açığını tespit edip kullanılabilirliğini test edebildiğini söyledi ” Hatanın CVSS puanı 10 üzerinden 9,9’dur ve bu da onu neredeyse maksimum şiddette bir güvenlik açığı haline getirmektedir Yeni açıklanan hatalar da benzer şekilde tehlikeli olabilir: MOVEit gibi kuruluşların sistemler, gruplar ve bireyler arasında güvenli dosya aktarımını sağlamak için kullandığı kurumsal düzeyde bir yazılım olan WS_FTP’nin desteklenen tüm sürümlerini etkilerler Bir düzeltme yayınladık ve müşterilerimizi yazılımımızın yamalı sürümüne yükseltme yapmaya teşvik ettik süreçler istek yükleri güvensiz bir şekilde CVE-2023-42657, 8 ”

Şunu ekliyor: “Ayrıca, WS_FTP sürümlerini çalıştırırken genellikle bağlantı isteklerini kabul etmek için gelen bağlantı noktaları açık olduğundan, ağ izleme araçlarıyla bunu tespit etmek zor olmaz